[RH - Gráficos] Problema con pokepic FR

Avisos


Like Tree7Gracias
Tema cerrado
 
Herramientas Desplegado
  #1  
18/03/2018
Predeterminado Problema con pokepic FR
Hola a todos
Tengo un problema con un showpokepic
Hice el script igual a como lo he hecho en ocasiones anteriores.
El problema es que cuando aparece el pokepic me aparece con un fondo negro, no blanco.



El mini al cual le hago el showpokepic es un mini al cual le cambié el tamaño:
De 16x16 a 32x32. No sé si tenga algo que ver
Dejo la info del OW por si algo


¿Alguien sabe cómo puedo solucionarlo?

Gracias
  #2  
18/03/2018
Predeterminado Re: Problema con pokepic FR
Mmm, se me ocurre que no cambiaste el color transparente al primero.

No entiendo a que te refieres con cambiar de 16x16 a 32x32, ya que el showpokepic muestra de 64x64
http://i.imgur.com/Dv57tio.png
  #3  
18/03/2018
Predeterminado Respuesta: Re: Problema con pokepic FR
Dicho por Marffy Ver mensaje
Mmm, se me ocurre que no cambiaste el color transparente al primero.

No entiendo a que te refieres con cambiar de 16x16 a 32x32, ya que el showpokepic muestra de 64x64
Pues, el sprite del pokepic no lo creé yo. Es el que viene por defecto del juego de FR.
Cuando digo lo de cambiar de 16x16 a 32x32 es el OW de RAPIDASH, no estoy hablando del pokepic.
  #4  
18/03/2018
Predeterminado Respuesta: Problema con pokepic FR
La verdad es que es un error “curioso”.
Sabes si ese error te sale en todos los showpokepic?
Prueba a hacerlo en otro mapa, lugar..
Para descartar posibles errores, que aunque no lo creais las roms originales los tienen, y de vez en cuando afloran cuando menos te lo esperas.

Despues de haber intentado eso, si el panorama sigue igual, mirate el sprite de rapidash original, a ver si rsta correctamente indexado, o si ha pasado algo con la imagen. (Podria pasarte que cambies el formato de indexacion de la imagen, aunque seria algo sumamente extraño..)

Para finalizar, examina las paletas en el palette viewer del VBA, a ver si es que se ha cambiado de color y si puedes cambiarlo con wbto.

No se me ocurre nada mas, si al fin y al cabo es ir tocando hasta que se vea bien.

Me voy de gira con la gamba mariachi.
¡Hasta siempre WAHeros!
  #5  
18/03/2018
Predeterminado Respuesta: Problema con pokepic FR
Mmm, mirando un poco, creo que el problema no va a estar en el pokepic sino en un doanimation.
Pues resulta que para llegar al lugar donde está el RAPIDASH debo hacer CORTE.



Y no me había dado cuenta y esta animación sale con colores errados.



Y si le hablo al RAPIDASH luego de hacer el CORTE sale el pokepic como he mostrado.
En cambio, si antes abro la POKEDEX o algo que refresque el mapa, sale bien



En este mapa hay varios árboles de CORTE, y en todos la animación sale igual.

Puse un árbol en otro mapa para ver como se veía, y se ve bien. (Con el mismo script)



No sé por qué ocurre esto.
¿Por qué puede pasar que en el otro mapa se vea la animación de CORTE con otros colores?

¿Cómo lo soluciono?

Gracias
  #6  
18/03/2018
Predeterminado Respuesta: Problema con pokepic FR
Por curiosidad, no estarás utilizando el sistema de paletas dinámicas para los overworlds, verdad?
Gracias: Inferno

Última edición por Samu; 18/03/2018 a las 23:01
  #7  
18/03/2018
Predeterminado Respuesta: Problema con pokepic FR
Dicho por Samu Ver mensaje
Por curiosidad, no estarás utilizando el sistema de paletas dinámicas para los overworlds, Verdad?
Sí, si lo estoy utilizando.
¿Tiene ese error?
  #8  
18/03/2018
Predeterminado Respuesta: Problema con pokepic FR
Dicho por hacanoca Ver mensaje
Sí, si lo estoy utilizando.
¿Tiene ese error?
Lo más probable es que haya un conflicto con esa rutina. Da bastantes problemas con todos los objetos que se montan con paletas del foreground. Haz lo que te dijo Eing más arriba para ver las paletas en el VBA y pasa imágenes de la ventana de las paletas en las 4 situaciones. (el showpokepic con el fondo negro, el showpokepic con el fondo blanco, el MO corte con los colores y sin los colores).
Con esa información igual puedo decirte algo.
Gracias: hacanoca
  #9  
18/03/2018
Predeterminado Re: Problema con pokepic FR
Puede que el problema esté relacionado al sistema de paletas dinámicas, pero sinceramente me parecería bastante raro, siendo que el error parece ser más de los background que de los objetos... A no ser que el sistema ese este haciendo algo bastante raro.

Pero para confirmar de donde proviene el problema, te podrías fijar en el Map viewer y OAM viewer de VBA y ver que es lo que tiene el fondo negro, si el background o el sprite:

Spoiler





Aunque el problema es bastante raro. Así como última opción lo podrías ignorar y usar la alternativa al showpokepic, loadmonsprite, de este tema: https://whackahack.com/foro/t-52486/...omandos-script
Gracias: hacanoca

o_O
  #10  
19/03/2018
Predeterminado Respuesta: Problema con pokepic FR
Dicho por Samu Ver mensaje
Lo más probable es que haya un conflicto con esa rutina. Da bastantes problemas con todos los objetos que se montan con paletas del foreground. Haz lo que te dijo Eing más arriba para ver las paletas en el VBA y pasa imágenes de la ventana de las paletas en las 4 situaciones. (el showpokepic con el fondo negro, el showpokepic con el fondo blanco, el MO corte con los colores y sin los colores).
Con esa información igual puedo decirte algo.
Bueno,
Aquí tengo las capturas.
A ver qué se te ocurre que pueda ser.

1) Animation sin colores adecuados


2) Pokepic con colores adecuados


3)Pokepic con colores no adecuados


4)Animation con colores adecuados


5)Mapa en el que falla el doanimation (antes de hacer cualquier cosa)


6)Mapa en el que no falla el doanimation (antes de hacer cualquiercosa)


Muchas gracias
Tema cerrado

Herramientas
Desplegado

Permisos para publicar mensajes
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los BB code están Activado
Los Emoticones están Activado
El código [IMG] está Activado
El Código HTML está Desactivado
Trackbacks are Activado
Pingbacks are Activado
Refbacks are Desactivado



Extra
Estilo clásico
La franja horaria es GMT +1. Ahora son las 17:12.

© Whack a Hack! 2019