Registrarse

[Essentials] Follow Me 1.4

montegom

Like no one ever was
Bueno viendo que el tutorial que hay en el listado de tutoriales está caído voy a pasar a hacer una traducción del tutorial de la última versión que hay del script Follow Me en Pokecommunity.

Los arreglos que trae esta versión por si alguien tiene una anterior son los siguientes:

*Se ha combinado todo en un script
*Se arregla la animación de la hierba
*Los NPC ya no traspasan al Pokemon que te sigue
*Ahora el Pokemon que te sigue puede hablarte aun con lluvia (antes no)
*Se han arreglado fallos que producían un crash en el juego
* Y más...
Para que el primer Pokemon de vuestro equipo os sigo en vuestro RPG debeís seguir estás instrucciones con cuidado.

Añade el siguiente script en una nueva sección encima de main y debajo del compilador:

[Ruby] Following Pokemon v1.4 - Pastebin.com

Guarda tu juego y cierra el RPG Maker.
Descarga este archivo: https://www.dropbox.com/s/vd80c1oscguz1zp/Animations.rxdata?dl=0
Descarga estos gráficos: https://www.dropbox.com/s/dcz25t76agm3giz/Animations.rar?dl=0
Ves a tu carpeta del juego y desde ahí a tu carpeta data, añade animations.rxdata que acabas de descargar y te pedirá que lo remplazes, di que sí.
Ahora ves a la carpeta de gráficos y desde ahí a la de animaciones, aquí tendrás que extraer, ojo extraer no arrastrar los archivos que descargaste (emo.png, emo2,png, and Pokemon-Follow.png).

Ya tenemos el script instalado, pero para ejecutarlo habrá que crear dos eventos en un mismo mapa.

El primero un evento vacío con cualquier ID.
El segundo evento desencadenará el script. Puede ser de cualquier manera con un mensaje, condiciones... pero al final deberá llamar al script pbPokemonFollow(X) donde la X es la ID del primer evento. Acordaros de que deben estar en el mismo mapa.

Créditos a:
Help-14
zingzangs
Rayd12smitty
Venom12
mej71
montegom (traducción)

Un mini tutorial:

Para forzar al sprite a que se refresque:

Código:
$PokemonTemp.dependentEvents.refresh_sprite
Para que el sprite acutalize su posición:

Código:
$NeedFollowerUpdate=true
 

Geo

El señor de las sombras
Buen tutorial estoy seguro que le servira a mas de uno de hecho a mi me hubiera servido hace unos meses
 
Esta versión supuestamente es para Pokémon Essentials 16.2, por lo que debería funcionar.

¿Podrías mandar una imagen del error?
Cree un evento en el mapa del laboratorio es el id 26, y en el evento de la pokeball cuando te da el pokemon le puse el script pbPokemonFollow(26).

 

Leviatan

Antisocial
es por la version de essentials, el script y los eventos no tienen nada que ver, usal la version de essentials 17
 

Luisi

Arrazando y mejorando
Re: Respuesta: Follow Me 1.4

Si encontre un video donde dice lo mismo que ya no funciona para 16.2 que solo funciona en v17 que sad. Muchas Gracias igual
Muy tarde pero aqui esta la solucion (creo):
Primero el archivo rxData que se descarga
Lo tienes que pasar cuando el programa/aplicación está cerrado
Si lo pasaste cuando el programa estaba abierto plantea error
Y vas a tener que pasarlo nuevamente pero con el programa cerrado despues tienes que ir al Script que copiaste de la página y lo pegaste arriba de Main bueno en ese script ve a la linea 1429 y la linea 1866 y cambia "PokemonPartyScreem" solo borra Party
 

Pableroski

Novato - Rpg en desarrollo
Tengo un problema con este script. Cuando lo activo me cambia al azar el valor de alguna de las variables
 

Jaizu

Decomp user
Tengo un problema con este script. Cuando lo activo me cambia al azar el valor de alguna de las variables
Está literalmente en las primeras líneas del script
Código:
Unused_Common_Event         = 5		  #Common event should be blank, but reserved
Following_Activated_Switch = 126      # Switch should be reserved
Toggle_Following_Switch = 103         # Switch should be reserved
Current_Following_Variable = 36       # Variable should be reserved
ItemWalk=26                           # Variable should be reserved
Walking_Time_Variable = 27            # Variable should be reserved
Walking_Item_Variable = 28            # Variable should be reserved
 

Mr Cramorant

Aprendiz de Leyenda
Me aparece este error que no se que será
Bueno viendo que el tutorial que hay en el listado de tutoriales está caído voy a pasar a hacer una traducción del tutorial de la última versión que hay del script Follow Me en Pokecommunity.

Los arreglos que trae esta versión por si alguien tiene una anterior son los siguientes:



Para que el primer Pokemon de vuestro equipo os sigo en vuestro RPG debeís seguir estás instrucciones con cuidado.

Añade el siguiente script en una nueva sección encima de main y debajo del compilador:

[Ruby] Following Pokemon v1.4 - Pastebin.com

Guarda tu juego y cierra el RPG Maker.
Descarga este archivo: https://www.dropbox.com/s/vd80c1oscguz1zp/Animations.rxdata?dl=0
Descarga estos gráficos: https://www.dropbox.com/s/dcz25t76agm3giz/Animations.rar?dl=0
Ves a tu carpeta del juego y desde ahí a tu carpeta data, añade animations.rxdata que acabas de descargar y te pedirá que lo remplazes, di que sí.
Ahora ves a la carpeta de gráficos y desde ahí a la de animaciones, aquí tendrás que extraer, ojo extraer no arrastrar los archivos que descargaste (emo.png, emo2,png, and Pokemon-Follow.png).

Ya tenemos el script instalado, pero para ejecutarlo habrá que crear dos eventos en un mismo mapa.

El primero un evento vacío con cualquier ID.
El segundo evento desencadenará el script. Puede ser de cualquier manera con un mensaje, condiciones... pero al final deberá llamar al script pbPokemonFollow(X) donde la X es la ID del primer evento. Acordaros de que deben estar en el mismo mapa.

Créditos a:
Help-14
zingzangs
Rayd12smitty
Venom12
mej71
montegom (traducción)

Un mini tutorial:

Para forzar al sprite a que se refresque:

Código:
$PokemonTemp.dependentEvents.refresh_sprite
Para que el sprite acutalize su posición:

Código:
$NeedFollowerUpdate=true
error.png
 

blue.trainer

Pequeño Saltamontes
Desde hace unos días encuentro el error 188 , eh consultado con otros que tienen el script y me dicen que les anda bien en su versión 16.2 alguien sabe de qué es este error? (Script "acompañante" línea 188: SyntaxError ocurred.)
 

masterguty31

Pequeño Saltamontes
Excepción: NoMethodError
Mensaje: undefined method `>' for nil:NilClass
RPG__Sprite:123:in `effect?'
RPG__Sprite:434:in `effect?'
RPG__Sprite:433:in `each'
RPG__Sprite:433:in `effect?'
AnimationSprite:31:in `update'
AnimationSprite:88:in `update'
AnimationSprite:87:in `each'
AnimationSprite:87:in `update'
Scene_Map:51:in `updateSpritesets'
Scene_Map:45:in `each'


ayuda este error me sale porfa
 
Arriba