Registrarse

[FR] Fallo insertando tile (no aparece)

Estado
Cerrado para nuevas respuestas.

Naren Jr.

Puto amo
Usuario de Platino
Importaste la paleta de los tiles que vas a meter? parece que ese es el fallo ya que se observa claramente que el tileset 1 tiene la paleta sin modificar, ese puede que sea tu fallo.

Debes cargar la paleta de los tiles que vas a meter en la ventana de palettes y load current palette, algo así ahora se me pasa, y cuando la cargues listo colocas tus tiles y ya.

Si tienes mas dudas sigue comentando, saludos >:3
 

CreandoPKMN

RoomHakeando Habitaciones
Puede pasar por varias razones.

1-Antes de insertar un tile, abre el tile con CMP, guarda la paleta, y importala en el advance map, después guarda el tileset, y ahí, insertas el tile, lo digo porque en la imagen que nos muestras el tileset sigue con las paletas originales.

2-Al cargar la paleta en el advance map, los colores cambian a colores de 15 bits (según lo que tengo entendido) y cambian un poco, pero es inapreciable, si el tile que vas a insertar no tiene los colores en 15 bits, se verá así, lo digo porque ya me ha pasado varias veces. Para poner que sea de 15 bits vas al CMP ->shift+e->Seleccionas todos los colores y das click donde dice: Colores 15 bits, guardas la imágen y vuelves a probar, deberían de verse bien.
 
Bueno, pues tras cargar la paleta es más de lo mismo:



Me queda así.

EDITO: Aún tengo que probar lo de CreandoPkm
 

Fran Agustín

L'amor està en l'aire
Bueno, pues tras cargar la paleta es más de lo mismo:



Me queda así.
EDITO: Aún tengo que probar lo de CreandoPkm
Agrego a lo que ya te dijo CreandoPkm:
  • El color de fondo debe estar en el primer lugar de la paleta.
  • Fijate bien que la imagen de los tiles esté guardada como PNG (puede tener problemas para abrirse con CMP), o como BMP de 24 bits (recomiendo ésta)
 

Dragonite

But where's your heart
Da toda la sensación de que insertaste un tile que no estaba indexado (por estar en una plantilla o algo así) y luego no reindexaste el tile (ya que si lo abres con herramientas como el Photoshop no detecta que el tileset está indexado).

Siempre cuando insertes tiles debes asegurarte de que el tileset esté indexado al momento de insertarlo.
 
Importaste la paleta de los tiles que vas a meter? parece que ese es el fallo ya que se observa claramente que el tileset 1 tiene la paleta sin modificar, ese puede que sea tu fallo.

Debes cargar la paleta de los tiles que vas a meter en la ventana de palettes y load current palette, algo así ahora se me pasa, y cuando la cargues listo colocas tus tiles y ya.

Si tienes mas dudas sigue comentando, saludos >:3
Por si todavía sigues con el problema, buscando un poco he encontrado este tutorial que seguro que te ayudará.
http://whackahack.com/foro/t-18181/gba-graficos-tu-tile-se-ve-verde
Da toda la sensación de que insertaste un tile que no estaba indexado (por estar en una plantilla o algo así) y luego no reindexaste el tile (ya que si lo abres con herramientas como el Photoshop no detecta que el tileset está indexado).

Siempre cuando insertes tiles debes asegurarte de que el tileset esté indexado al momento de insertarlo.

Bueno, ya miré el tutorial ese y nada. Y ya cargué la paleta del tile y ya está puesto en el primer puesto en color de fondo. También lo de darle a colores de 15 bits en el CMP.

Mejor debería probar con un tile ya indexado primero.
 
Ami me paso eso con las montañas en fire red lo resolvi viendo las paletas del tile ya indexedo, copie la rom y abri de nuevo el advance map con la rom copiada ovbio ya tiene cargado la paleta del tile a insertar entonces entre a show palletes y sorpresa se me repetia el color negro como 4 veces(cuadros con las paletas) entonses abri el tile en CMP y apartir del ultimo color del tile cambie las cuatros paletas que eran de color negro, los puse de colores que fueran cafes por las montañas, en tu caso sera verdes resumiendo cuenta los colores que se repitan en el show palletes , edita las paletas que se repiten en el CMP indexalo guarda la paleta y el tile entonces ya procedes en el AM a insertar la pallete y procedes a guardar el tileset 1 y a insertar el tile , eso te deberia de servir :3 por lo menos ami si me funciono, los colores del tile se pueden editar pero una ves adentro creo que se los puedes cambiar ya sea con paint o con el editor que uses, perdon por escribir tanto y perdon si no me entiendes pero soy nuevo :3, suerte bro :3
 
Estado
Cerrado para nuevas respuestas.
Arriba