Registrarse

[RPG - Scripting] Pokemon acompañante error en el script

Estado
Cerrado para nuevas respuestas.

Morel X

Pues bueno aquí estamosxD
Buenas, pues quise poner lo de pokémon acompañante para cuando al recibir mi primer pokémon saliera y me siguiera, lo del heartgold y soulsilver vamos, y pues he seguido este tutorial: https://www.pokecommunity.com/showthread.php?t=360846


Pero cuando voy a iniciar el juego me da un error que dice esto:

????? 'PokemonAcompañante'? 1431 ??? NameError ???????

undefined method `pbSwitch' for class `PokemonPartyScreen'


El error es aquí:

#Refresh following pokemon after switching pokemon around
class PokemonPartyScreen

alias follow_pbSwitch pbSwitch
def pbSwitch(oldid,newid)
follow_pbSwitch(oldid,newid)
$PokemonTemp.dependentEvents.refresh_sprite(false)
end

alias follow_pbRefreshSingle pbRefreshSingle
def pbRefreshSingle(pkmnid)
follow_pbRefreshSingle(pkmnid)
$PokemonTemp.dependentEvents.refresh_sprite(false)
end

end

#Refresh after evolution
class PokemonEvolutionScene

alias follow_pbEndScreen pbEndScreen
def pbEndScreen
follow_pbEndScreen
if @pokemon==$Trainer.party[0]
$PokemonTemp.dependentEvents.refresh_sprite(false)
end
end

end


Se que es en los dos porque probé borrando el primero y despues me daba error el otro y si borro los dos funciona pero al hablarle al pokémon que te sigue da otro error, alguien sabe como solucionarlo?
 

kurugane

Tan antiguo como las Rocas.
Bueno , para empezar suponiendo que estas usando essentials 17.x, que es para la versión que esta programado el script, y seguiste al PIE de la letra las instrucciones, tal vez sea algo de tu partida, intenta instalarlo desde 0, o si no, usando el UPI, que te instala todos esos scripts automaticamente, solo asegurate que tu internet te deje acceder a Pastebin, cualquier duda mandame un MP y te contesto con gusto.
 
Yo te recomendaría volver a poner el Script a mi me pasaba lo mismo y pues resulta que el Script tenia un pequeño error de escritura, pero en el post oficial (osea ese link que tienes ahí) hubo una pequeña actualizacion, asi que prueba a pegar el Script una vez mas y tambien revisa las notas que le colocaste al evento de cuando debe ejecutarse el Script, ya que por una simple letra se te puede dañar todo, ademas de que debe ir con todo y sus signos, aun así te sugiero que vuelvas al Link y chequees bien el Script, a mi me funciono hace unos minutos, si necesitas alguna repuesta o algo me dices por mensaje y puede que te ayude con una Scan o algo. Saludos :)
 

Morel X

Pues bueno aquí estamosxD
Bueno , para empezar suponiendo que estas usando essentials 17.x, que es para la versión que esta programado el script, y seguiste al PIE de la letra las instrucciones, tal vez sea algo de tu partida, intenta instalarlo desde 0, o si no, usando el UPI, que te instala todos esos scripts automaticamente, solo asegurate que tu internet te deje acceder a Pastebin, cualquier duda mandame un MP y te contesto con gusto.
Ah pues yo estoy usando la ultima que hay en español, será eso, hay alguna forma de hacer que funcione en mi version? la 16.2 es

Yo te recomendaría volver a poner el Script a mi me pasaba lo mismo y pues resulta que el Script tenia un pequeño error de escritura, pero en el post oficial (osea ese link que tienes ahí) hubo una pequeña actualizacion, asi que prueba a pegar el Script una vez mas y tambien revisa las notas que le colocaste al evento de cuando debe ejecutarse el Script, ya que por una simple letra se te puede dañar todo, ademas de que debe ir con todo y sus signos, aun así te sugiero que vuelvas al Link y chequees bien el Script, a mi me funciono hace unos minutos, si necesitas alguna repuesta o algo me dices por mensaje y puede que te ayude con una Scan o algo. Saludos :)
Lo que creo que es el problema es lo que han dicho arriba que es para la version 17 y yo uso la 16.2, habrá alguna forma de que funcione en mi version?
 
Re: Respuesta: Pokemon acompañante error en el script

Ah pues yo estoy usando la ultima que hay en español, será eso, hay alguna forma de hacer que funcione en mi version? la 16.2 es



Lo que creo que es el problema es lo que han dicho arriba que es para la version 17 y yo uso la 16.2, habrá alguna forma de que funcione en mi version?
Si estas usando la version 16.2 ese es el problema en la versión de 17.2 y 16.2 son distintas formas de activar este Script. Bueno en todo caso si deseas seguir con la 16.2 aca te dejo un Link de un video que lo explics de forma detallada y muy rápida: https://youtu.be/w6kCrg_uHDo
Si deseas cambiarte a la 17.2 pues actualizala y luego pon el Script que tienes ahi en el Link. Es todo.
 

Morel X

Pues bueno aquí estamosxD
Respuesta: Re: Respuesta: Pokemon acompañante error en el script

Si estas usando la version 16.2 ese es el problema en la versión de 17.2 y 16.2 son distintas formas de activar este Script. Bueno en todo caso si deseas seguir con la 16.2 aca te dejo un Link de un video que lo explics de forma detallada y muy rápida: https://youtu.be/w6kCrg_uHDo
Si deseas cambiarte a la 17.2 pues actualizala y luego pon el Script que tienes ahi en el Link. Es todo.
Ese vídeo es el primero que seguí para hacerlo pero me daba error tambien, es para la version 16.2? y no lo actualizo porque las cosas se pondrían en inglés no?
 
Re: Respuesta: Re: Respuesta: Pokemon acompañante error en el script

Ese vídeo es el primero que seguí para hacerlo pero me daba error tambien, es para la version 16.2? y no lo actualizo porque las cosas se pondrían en inglés no?
Si es para la 16.2, pero no se porque te da error entonces. Yo que fuera tu mejor actualizo la versión más reciente de Pokemon Essentials, ya que la 16.2 no sé, no la utilizo y tampoco estoy seguro de que se pondrian las cosas en Ingles, eso depende si tienes el Essentials en Español, ahí si se pondria en Ingles.
 

Morel X

Pues bueno aquí estamosxD
Respuesta: Re: Respuesta: Re: Respuesta: Pokemon acompañante error en el script

Si es para la 16.2, pero no se porque te da error entonces. Yo que fuera tu mejor actualizo la versión más reciente de Pokemon Essentials, ya que la 16.2 no sé, no la utiliz y tampoco estoy seguro de que se pondrian las cosas en Ingles, eso depende si tienes el Essentials en Español, ahí si se pondria en Ingles.
Si, lo tengo en español y quiero seguir así jaja, bueno ya veré más adelante si consigo ponerlo supongo
 

KleinStudio

Un plato es un plato
Miembro del equipo
Webmaster
La clase PokemonPartyScreen no existe en la v16.
Por lo que veo, en general todo el script ya está adaptado para que funcione en la v17, la verdad es que no te puedo recomendar que estés en una versión antigua por mucho que esté en español pero si es lo que quieres lo único que puedes hacer es contactar con el autor del script (el cual según veo ha pasado bastante de este tema), empezar a ponerle parches al script y acabar haciendo una especie de versión frankestein entre la v16 y la v17 o buscar una versión antigua del script que todavía funcione en la v16 (¿quizás algún miembro del foro tenga alguna copia más antigua?).
 

Morel X

Pues bueno aquí estamosxD
La clase PokemonPartyScreen no existe en la v16.
Por lo que veo, en general todo el script ya está adaptado para que funcione en la v17, la verdad es que no te puedo recomendar que estés en una versión antigua por mucho que esté en español pero si es lo que quieres lo único que puedes hacer es contactar con el autor del script (el cual según veo ha pasado bastante de este tema), empezar a ponerle parches al script y acabar haciendo una especie de versión frankestein entre la v16 y la v17 o buscar una versión antigua del script que todavía funcione en la v16 (¿quizás algún miembro del foro tenga alguna copia más antigua?).
Supongo que esas son mis opciones si jajaa, quien crees que pueda tener esa copia antigua de la que hablas y pueda preguntarle?
 
Estado
Cerrado para nuevas respuestas.
Arriba