Registrarse

¿Por qué no funcionan mis herramientas?

Pues bueno, como he visto que hay muchos temas diciendo que no le funcionan las herramientas,(Y ya que Landey me lo ha pedido...), que si problemas con los componentes, etc.. pues he abierto el tema para ir poniendo aquí las dudas mas generales para evitar un poco la saturación del subforo.


1. No me funcionan las herramientas
Entonces necesitas unos componentes para que funcionen.
Los componentes puedes encontrarlos en este otro post del foro, donde hay 2 packs de componentes para descargar, el de Gershel y otro mio.

Para mas información, visita el post mencionado:
DESCARGA DE COMPONENTES

EDITADO por cosarara97:
Mirror


Editado por Cheve:
http://www.mediafire.com/file/897d1da90i1jllh/Pack_DLL.zip
(Contiene COMCTL32.OCX, COMDLG32.OCX, MSCOMCTL.OCX, FM20.DLL, MSSTDFMT.DLL)



2. Vale, ya tengo los componentes, ¿y ahora que?
Pues muy sencillo, solo tienes que copiarlos a la carpeta del programa, y a %systemroot%/system32 (Por defecto esta ruta suele ser C:\WINDOWS\system32)



3. Pues acabo de hacer eso y sigue sin funcionar...
En ese caso querido amigo/a debes registrar los componentes en WINDOWS... ¿Que como lo haces?, pues muy sencillo sigue los siguientes pasos:
Pasos a seguir:
1. Vamos a Inicio
2. Le damos a ejecutar, o en windows Vista y 7 en el cuadradito que pone buscar.
3. Escribimos "cmd" (sin las comillas)
y aparecera una ventanita negra donde debemos escribir lo siguiente:

4. Regsvr32 <nombre del fichero>

Por ejemplo:

REGSVR32 c:\windows\system32\msstdfmt.dll

Los parámetros opcionales [/u] [/s] significan lo siguiente:

[/u] - lo utilizamos cuando queremos "desregistrar" una DLL (o un .ocx en vez de registrarlo).
EJ: REGSVR32 [/u] c:\windows\system32\msstdfmt.dll

[/s] - modo "silencioso" - no despliega los mensajes durante la operación.
EJ: REGSVR32 [/s] c:\windows\system32\msstdfmt.dll

Eso es todo.


4. Compatibilidad
Este ya es un tema mas delicado, depende del pc de cada uno, y lo primero que debes saber es:

¿Que SO(Sistema Operativo) usas?
Entonces seguramente hayas hecho algo mal... revísalo de nuevo.
Si ves que lo has hecho bien, asegurate de que tienes instalado la ultima versión del .NET FRAMEWORK, y si ya tenias una instalada tienes que desinstalarla antes
NET FRAMEWORK
Pues a pesar de que en sus principios era incompatible hasta con el mismo, micrisoft se ha esmerado en solucionarlo, asique existe una posible manera de compatibilidad:
Vaya al punto 1, descargue el pack de NEMESYS(Pack 2), en el se encuentra un archivo llamado Msvbvm50.dll, este sirve para hacer compatibles algunas herramientas con WIN VISTA, solo debes ponerlos en las mismas rutas del punto 2.
También podemos darle a click derecho sobre el programa y ponerlo en modo compatibilidad con WINXP, pero yo no le pondría muchas esperanzas...

Es un SO nuevo, y como al vista le paso, y es posible que haya incompatibilidades..., a pesar de ello, para los usuarios que tengan la suerte de poseer WIN7 Professional/Ultimate/Enterprise, existe un modo de compatibilidad llamado "WINDOWS XP MODE" el cual puede ser descargado de Aquí
Con este "WINDOWS XP MODE" podras ejecutar herramientas y programas de WIN XP en WIN 7, y es totalmente gratuito.

Los que no gozen de ello, todavia tienen la opcion del modo administrador, dandole a click derecho sobre el programa y elegimos ejecutar como administrador.

PD: Si usas un WIN 7 pirata, y eres perjudicado por instalar el WINXPMODE, yo no asumo los riesgos, tu decides si lo haces o no.
En el caso de que estes usando Linux, y quieras hackear en el, Wine es tu aplicacion.
¿Que es WINE?
Pues vamos a decir que es una aplicacion que se encarga de emular los programas de WINDOWS en Linux, para instalarlo hay varias opciones...
(En sistemas Debian y derivados, como Ubuntu o Mint)
Simplemente abre una terminal, y escribe:
sudo apt-get install wine
y pulsa ENTER y deberia instalarse

NOTA: Para usar este método debes ser Administrador del sistema, si no lo eres, antes deberías loguearte como root y luego escribir el comando en consola.

Vamos a aplicaciones, hacemos click en Centro de Software de LINUX, y luego escribimos en el cuadro de dialogo Wine, y lo instalamos.

Para mas informacion a cerca de wine Visita esta pagina


Y eso es todo, si alguien ve que me he dejado algo o quiere añadir algo, que me lo diga, y editare el post.

PD: Agradecimientos a Gershel por su Pack de herramientas.
PD2: No sabia si ponerlo en tutoriales o en dudas, pero como es el foro de dudas el mas afectado he decidido escribirlo aquí, si algun mod decide que su lugar es en tutoriales que lo mueva, y ya que estamos que borre esta Postdata xD
PD3: Evitad los comentarios tipo "gracias, buen aporte", usad el boton de gracias, para mantener el tema lo mas "limpio" posible
 
Última edición por un moderador:

Landey

Rom Hacker
Yeah!
Colgado en importantes,gracias hermano.

A partir de ahora toda duda que tenga que ver con herramientas va a ir aqui,
no son manuales ni nada parecido para que vengan a spamear con sus "gracias"
esto es ahora un hilo de resolucion de dudas.
 

Chrono

Chúpate el codo.
Tambien se encuentra otra forma para hacer funcionar las herremientas en el windows 7
es darle clic derecho sobre el programa que queramos abrir
ponemos ejecutar como administrador
despues nos aparecera un recuadro donde le damos que si y listo
asi lo hago yo y no tuve que bajar el "windows xp mode"
 
CHarizard-Shiny dijo:
Tambien se encuentra otra forma para hacer funcionar las herremientas en el windows 7
es darle clic derecho sobre el programa que queramos abrir
ponemos ejecutar como administrador
despues nos aparecera un recuadro donde le damos que si y listo
asi lo hago yo y no tuve que bajar el "windows xp mode"
Cierto es, con tanto escribir se me olvido ponerlo xD, ahora mismo lo añado xD
Aunque esto solo puede ser usado por el administrador del equipo, ademas lo del winxpmode es en caso de incompatibilidad, cosa que ati no te ocurre
 

Feliipe

Usuario de Oro
Hola no me anda el NSE no me arranca me dice erro 00001350 o algo asi
¿alguien sabe como solucionarlo?
 
Takeru dijo:
Hola no me anda el NSE no me arranca me dice erro 00001350 o algo asi
¿alguien sabe como solucionarlo?
Pues te recomiendo bajar los componentes de nuevo, y si sigue sin funcionar, prueba a registrarlos :S, sino ya sería cosa de tu PC, xk ese error es una dirección de memoria.
 
oye eso no seria por el framework es que esa herramienta es echa en el visual basic y requiere el framework 3.0 o 3.5 para andar tambien susede con la serie avanzada :D
 

Feliipe

Usuario de Oro
Si creo que tenie el 3.5 pero formatie mi equipo como se llama para buscarla y bajarla
(nombrecompleto)
 
jejejje tienes suerte men yo ando en las mismas por la formatiada y ahora mismo lo ando instalando mira te paso el link
aki los podras descargar si ya tienes unos instalado desinstalalo por medio de quitar o agregar progrmas recuerda es el que diga microsoft framework y ay esta la version que tiene no no tienes ninguna version instalalo normal ^^
 

Feliipe

Usuario de Oro
Vale gracias...como no tengo ninguno lo instalare facil...
y si necesito algo sobre una herramienta ya se que se postea aqui
 
Takeru dijo:
Vale gracias...como no tengo ninguno lo instalare facil...
y si necesito algo sobre una herramienta ya se que se postea aqui
Lo del NET Framework es un problema usual, si hubieras dicho que acabas de formatear pues te lo hubiese dicho :S pero por el error no se me habria ocurrido :S
 
¿Alguien sabe como funciona el Easy Script Maker? Me pide el archivo:
WinXPC Engine.ocx, pero en el pack que ha puesto Nemesys no viene ese archivo.
 

Feliipe

Usuario de Oro
Te recomiendo que uses XSE el que quieres usar esta en spañol y todo pero creeme
no es muy facil porque no todas las palabras estan traducidas y si tuienes dudas todos e
diran que mejor uses XSE
 

Lunos

Enfrentando a La Organización
Excelentes Paquetes Ambos :3 aunque es raro lo que dices,digo,yo me baje un paquete que tenia los 5 Windows 7 (Starter,Home basic/premium,professional y ultimate) tengo el Ultimate y sin bajar nada me vino la compatibilidad con WinXP sp1,sp2,sp3 aunque bueno no es que interese :3 MUCHISIMAS gracias por el paquete u.u thingy ya me tiraba error


Paz~
 
tengo un problema con sappy(que lo tube hace mucho tiempo pero ya no me sirve la solucion) cuando lo abro me sale esto:

ya intente con un instalador que me habia dado eing(con el cual lo arregle la primera vez) y no me funciona y tambien ya probe registrando manualmente el ocx y nada... Es en Windows 7 y ya se que existe el windows xp mode pero mi pc no lo soporta
 
DaWolf dijo:
tengo un problema con sappy(que lo tube hace mucho tiempo pero ya no me sirve la solucion) cuando lo abro me sale esto:

ya intente con un instalador que me habia dado eing(con el cual lo arregle la primera vez) y no me funciona y tambien ya probe registrando manualmente el ocx y nada... Es en Windows 7 y ya se que existe el windows xp mode pero mi pc no lo soporta
Los 2 errores te saltan seguidos? si es asi, el problema es el primer error, sino son 2 distintos.

Según lo que he leido por ahí es un error común de las DLL y los OCX, y buscando alguna solucion encontre esto:
Run-Time Error 429 - ActiveX Cannot Create Component:

Has lo siguiente:
1.) Pon la resolucion de colores en 16 bit.

Descarga estos archivos:

dx7vb.dll: http://www.savefile.com/files/1886091
dao350: http://www.savefile.com/files/1886099

Run-Time Error 372 - MSComm32.ocx:

MSComm32.ocx es un archivo que necesariamente no es obligatorio que este en la PC. es necesario registrarlo tambien!. Este archivo viene en el "Solucionador de Problemas". Luego insertalo en la carpeta "WINDOWS/System32"

Para registrarlo debes ir a : Inicio > Ejecutar > Escribe: Regsvr32 MSComm32.ocx
 
Lo que me pasa es que cuando abro el sappy me sale el primer error, luego le doy aceptar y me sale el segundo.. y ya me descargue esos archivos y el mscomm32 y lo registre pero me sigue tirando esos errores...
 
DaWolf dijo:
Lo que me pasa es que cuando abro el sappy me sale el primer error, luego le doy aceptar y me sale el segundo.. y ya me descargue esos archivos y el mscomm32 y lo registre pero me sigue tirando esos errores...
Has puesto la resolucion de colores en 16 bit? si es asi, no tengo ni idea de porque pasa :S, sino pruebalo u.u'
 
Arriba