[Essentials] Follow Me 1.4

Avisos


Like Tree6Gracias
Respuesta
 
Herramientas Desplegado
  #1  
07/01/2017
Información Follow Me 1.4
Bueno viendo que el tutorial que hay en el listado de tutoriales está caído voy a pasar a hacer una traducción del tutorial de la última versión que hay del script Follow Me en Pokecommunity.

Los arreglos que trae esta versión por si alguien tiene una anterior son los siguientes:

*Se ha combinado todo en un script
*Se arregla la animación de la hierba
*Los NPC ya no traspasan al Pokemon que te sigue
*Ahora el Pokemon que te sigue puede hablarte aun con lluvia (antes no)
*Se han arreglado fallos que producían un crash en el juego
* Y más...
Para que el primer Pokemon de vuestro equipo os sigo en vuestro RPG debeís seguir estás instrucciones con cuidado.

Añade el siguiente script en una nueva sección encima de main y debajo del compilador:

[Ruby] Following Pokemon v1.4 - Pastebin.com

Guarda tu juego y cierra el RPG Maker.
Descarga este archivo: https://www.dropbox.com/s/vd80c1oscg...ns.rxdata?dl=0
Descarga estos gráficos: https://www.dropbox.com/s/dcz25t76ag...tions.rar?dl=0
Ves a tu carpeta del juego y desde ahí a tu carpeta data, añade animations.rxdata que acabas de descargar y te pedirá que lo remplazes, di que sí.
Ahora ves a la carpeta de gráficos y desde ahí a la de animaciones, aquí tendrás que extraer, ojo extraer no arrastrar los archivos que descargaste (emo.png, emo2,png, and Pokemon-Follow.png).

Ya tenemos el script instalado, pero para ejecutarlo habrá que crear dos eventos en un mismo mapa.

El primero un evento vacío con cualquier ID.
El segundo evento desencadenará el script. Puede ser de cualquier manera con un mensaje, condiciones... pero al final deberá llamar al script pbPokemonFollow(X) donde la X es la ID del primer evento. Acordaros de que deben estar en el mismo mapa.

Créditos a:
Help-14
zingzangs
Rayd12smitty
Venom12
mej71
montegom (traducción)

Un mini tutorial:

Para forzar al sprite a que se refresque:

Código:
$PokemonTemp.dependentEvents.refresh_sprite
Para que el sprite acutalize su posición:

Código:
$NeedFollowerUpdate=true
  #2  
07/01/2017
Predeterminado Respuesta: Follow Me 1.4
Buen tutorial estoy seguro que le servira a mas de uno de hecho a mi me hubiera servido hace unos meses
  #3  
17/10/2018
Predeterminado Respuesta: Follow Me 1.4
me da error al abrir el juego uso essentials 16.2
  #4  
17/10/2018
Predeterminado Respuesta: Follow Me 1.4
Dicho por ZiniHernan Ver mensaje
me da error al abrir el juego uso essentials 16.2
Esta versión supuestamente es para Pokémon Essentials 16.2, por lo que debería funcionar.

¿Podrías mandar una imagen del error?
  #5  
17/10/2018
Predeterminado Respuesta: Follow Me 1.4
Dicho por White, el niño con barba Ver mensaje
Esta versión supuestamente es para Pokémon Essentials 16.2, por lo que debería funcionar.

¿Podrías mandar una imagen del error?
Cree un evento en el mapa del laboratorio es el id 26, y en el evento de la pokeball cuando te da el pokemon le puse el script pbPokemonFollow(26).

  #6  
17/10/2018
Predeterminado Respuesta: Follow Me 1.4
es por la version de essentials, el script y los eventos no tienen nada que ver, usal la version de essentials 17
Nichts ist für dich
Nichts war für dich
Nichts bleibt für dich
  #7  
17/10/2018
Predeterminado Respuesta: Follow Me 1.4
He encontrado este post en el que dice que el script es para la v16 y el script es idéntico al de este post.
Por lo que no es un error de versión.

Following Pokemon v 1.4 [v16]
  #8  
17/10/2018
Predeterminado Respuesta: Follow Me 1.4
Dicho por White, el niño con barba Ver mensaje
He encontrado este post en el que dice que el script es para la v16 y el script es idéntico al de este post.
Por lo que no es un error de versión.

Following Pokemon v 1.4 [v16]
Tambien habia intentado con ese post y me sale el mismo error.
  #9  
17/10/2018
Predeterminado Respuesta: Follow Me 1.4
Dicho por ZiniHernan Ver mensaje
Tambien habia intentado con ese post y me sale el mismo error.
Pruebalo en un proyecto sin modificaciones. (Obviamente que sea de la misma versión que tu proyecto)
  #10  
18/10/2018
Predeterminado Respuesta: Follow Me 1.4
Dicho por White, el niño con barba Ver mensaje
Pruebalo en un proyecto sin modificaciones. (Obviamente que sea de la misma versión que tu proyecto)
Lo probe en un nuevo proyecto y sale el mismo error.
Respuesta

Herramientas
Desplegado

Permisos para publicar mensajes
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los BB code están Activado
Los Emoticones están Activado
El código [IMG] está Activado
El Código HTML está Desactivado
Trackbacks are Activado
Pingbacks are Activado
Refbacks are Desactivado



Extra
Estilo clásico
La franja horaria es GMT +1. Ahora son las 23:39.

© Whack a Hack! 2019